Potential sensitive data exposure in applications using Vaadin 15
CVE-2020-36319GHSA-rjww-2x8v-m9v9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.vaadin:flow-server 3.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.vaadin:flow-server
- Affected
- >= 3.0.0, < 3.0.6
- Fixed in
- 3.0.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rjww-2x8v-m9v9 lists affected ranges: Maven com.vaadin:flow-server >=3.0.0 <3.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 3.1 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-36319: 1.00% estimated exploitation activity in the next 30 days; percentile 62.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Insecure configuration of default ObjectMapper in com.vaadin:flow-server versions 3.0.0 through 3.0.5 (Vaadin 15.0.0 through 15.0.4) may expose sensitive data if the application also uses e.g. @RestController - https://vaadin.com/security/cve-2020-36319
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rjww-2x8v-m9v9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36319 Advisory: Potential sensitive data exposure in applications using Vaadin 15 IDs: CVE-2020-36319, GHSA-rjww-2x8v-m9v9 Record: https://patchnext.com/advisories/cve-2020-36319 (revision 1, source checked 26 Oct 2026, 16:02 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 3.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.vaadin:flow-server 3.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.vaadin:flow-server: affected >= 3.0.0, < 3.0.6; fixed in 3.0.6 ## Suggested inspection (read-only) - Maven com.vaadin:flow-server: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.vaadin:flow-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rjww-2x8v-m9v9 (GitHub-reviewed advisory GHSA-rjww-2x8v-m9v9 lists affected ranges: Maven com.vaadin:flow-server >=3.0.0 <3.0.6) Commands are suggestions: review each one before running it.
Loading voting…