Skip to content

← Actionable
High, CVSS 7.0

Data races in gfwx

CVE-2020-36211GHSA-xp6v-qx65-4pp7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (gfwx 0.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io gfwx

    Affected
    < 0.3.0
    Fixed in
    0.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-36211: 0.35% estimated exploitation activity in the next 30 days; percentile 28.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In the affected versions of this crate, ImageChunkMut<', T unconditionally implements Send and Sync, allowing to create data races. This can result in a memory corruption or undefined behavior when non thread-safe types are moved and referenced across thread boundaries. The flaw was corrected in commit e7fb2f5 by adding T: Send bound to the Send impl and adding T: Sync bound to the Sync impl.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-xp6v-qx65-4pp7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-36211

Advisory: Data races in gfwx
IDs: CVE-2020-36211, GHSA-xp6v-qx65-4pp7
Record: https://patchnext.com/advisories/cve-2020-36211 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: gfwx 0.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io gfwx: affected < 0.3.0; fixed in 0.3.0

## Suggested inspection (read-only)
- crates.io gfwx: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on gfwx.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-xp6v-qx65-4pp7 (GitHub-reviewed advisory GHSA-xp6v-qx65-4pp7 lists affected ranges: crates.io gfwx >=0 <0.3.0)

Commands are suggestions: review each one before running it.

Loading voting…