Resource exhaustion in socket.io-parser
CVE-2020-36049GHSA-xfhh-g9f5-x4m4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (socket.io-parser 3.4.1, 3.3.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm socket.io-parser
- Affected
- < 3.3.2>= 3.4.0, <= 3.4.0
- Fixed in
- 3.4.1, 3.3.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xfhh-g9f5-x4m4 lists affected ranges: npm socket.io-parser >=0 =3.4.0 <3.4.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xfhh-g9f5-x4m4 lists affected ranges: npm socket.io-parser >=0 =3.4.0 <=3.4.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-36049: 2.67% estimated exploitation activity in the next 30 days; percentile 85.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The socket.io-parser npm package before versions 3.3.2 and 3.4.1 allows attackers to cause a denial of service (memory consumption) via a large packet because a concatenation approach is used.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-xfhh-g9f5-x4m4
- Revision 1 · created ·
Published from osv record GHSA-xfhh-g9f5-x4m4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-36049 Advisory: Resource exhaustion in socket.io-parser IDs: CVE-2020-36049, GHSA-xfhh-g9f5-x4m4 Record: https://patchnext.com/advisories/cve-2020-36049 (revision 2, source checked 26 Oct 2026, 12:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: socket.io-parser 3.4.1, 3.3.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm socket.io-parser: affected < 3.3.2; >= 3.4.0, <= 3.4.0; fixed in 3.4.1, 3.3.2 ## Suggested inspection (read-only) - `npm ls socket.io-parser --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on socket.io-parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-xfhh-g9f5-x4m4 (OSV record GHSA-xfhh-g9f5-x4m4 lists affected ranges: npm socket.io-parser >=0 =3.4.0 <3.4.1 (fixed)) - Verified: https://github.com/advisories/GHSA-xfhh-g9f5-x4m4 (GitHub-reviewed advisory GHSA-xfhh-g9f5-x4m4 lists affected ranges: npm socket.io-parser >=0 =3.4.0 <=3.4.0) Commands are suggestions: review each one before running it.
Loading voting…