Skip to content

← Actionable
Medium, CVSS 4.7

Data races in lock_api

CVE-2020-35912GHSA-5wg8-7c9q-794v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (lock_api 0.4.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io lock_api

    Affected
    < 0.4.2
    Fixed in
    0.4.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.7 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-35912: 0.21% estimated exploitation activity in the next 30 days; percentile 11.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in the lockapi crate before 0.4.2 for Rust. A data race can occur because of MappedRwLockWriteGuard unsoundness.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5wg8-7c9q-794v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35912

Advisory: Data races in lock_api
IDs: CVE-2020-35912, GHSA-5wg8-7c9q-794v
Record: https://patchnext.com/advisories/cve-2020-35912 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: lock_api 0.4.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io lock_api: affected < 0.4.2; fixed in 0.4.2

## Suggested inspection (read-only)
- crates.io lock_api: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lock_api.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5wg8-7c9q-794v (GitHub-reviewed advisory GHSA-5wg8-7c9q-794v lists affected ranges: crates.io lock_api >=0 <0.4.2)

Commands are suggestions: review each one before running it.

Loading voting…