Skip to content

← Actionable
Critical, CVSS 9.8

HTTP Request Smuggling in hyper

CVE-2020-35863GHSA-h3qr-rq2j-74w4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hyper 0.12.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io hyper

    Affected
    >= 0.11.0, < 0.12.34
    Fixed in
    0.12.34

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-35863: 2.97% estimated exploitation activity in the next 30 days; percentile 87.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerable versions of hyper allow GET requests to have bodies, even if there is no Transfer-Encoding or Content-Length header. As per the HTTP 1.1 specification, such requests do not have bodies, so the body will be interpreted as a separate HTTP request. This allows an attacker who can control the body and method of an HTTP request made by hyper to inject a request with headers that would not otherwise be allowed, as demonstrated by sending a malformed HTTP request from a Substrate runtime. This allows bypassing CORS restrictions. In combination with other vulnerabilities, such as an exploitable web server listening on loopback, it may allow remote code execution. The flaw was corrected in hyper version 0.12.34.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-h3qr-rq2j-74w4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35863

Advisory: HTTP Request Smuggling in hyper
IDs: CVE-2020-35863, GHSA-h3qr-rq2j-74w4
Record: https://patchnext.com/advisories/cve-2020-35863 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hyper 0.12.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io hyper: affected >= 0.11.0, < 0.12.34; fixed in 0.12.34

## Suggested inspection (read-only)
- crates.io hyper: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hyper.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-h3qr-rq2j-74w4 (GitHub-reviewed advisory GHSA-h3qr-rq2j-74w4 lists affected ranges: crates.io hyper >=0.11.0 <0.12.34)

Commands are suggestions: review each one before running it.

Loading voting…