Skip to content

← Actionable
Critical, CVSS 9.8

Out of bounds write in prost

CVE-2020-35858GHSA-gv73-9mwv-fwgq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (prost 0.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io prost

    Affected
    < 0.6.1
    Fixed in
    0.6.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-35858: 3.40% estimated exploitation activity in the next 30 days; percentile 88.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Affected versions of this crate contained a bug in which decoding untrusted input could overflow the stack. On architectures with stack probes (like x86), this can be used for denial of service attacks, while on architectures without stack probes (like ARM) overflowing the stack is unsound and can result in potential memory corruption (or even RCE).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-gv73-9mwv-fwgq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35858

Advisory: Out of bounds write in prost
IDs: CVE-2020-35858, GHSA-gv73-9mwv-fwgq
Record: https://patchnext.com/advisories/cve-2020-35858 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: prost 0.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io prost: affected < 0.6.1; fixed in 0.6.1

## Suggested inspection (read-only)
- crates.io prost: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on prost.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-gv73-9mwv-fwgq (GitHub-reviewed advisory GHSA-gv73-9mwv-fwgq lists affected ranges: crates.io prost >=0 <0.6.1)

Commands are suggestions: review each one before running it.

Loading voting…