Skip to content

← Actionable
High, CVSS 7.5

Stack consumption in trust-dns-server

CVE-2020-35857GHSA-4cww-f7w5-x525

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (trust-dns-server 0.18.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-35857: 1.46% estimated exploitation activity in the next 30 days; percentile 73.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

There's a stack overflow leading to a crash and potential DOS when processing additional records for return of MX or SRV record types from the server. This is only possible when a zone is configured with a null target for MX or SRV records. Prior to 0.16.0 the additional record processing was not supported by trust-dns-server. There Are no known issues with upgrading from 0.16 or 0.17 to 0.18.1. The remidy should be to upgrade to 0.18.1. If unable to do so, MX, SRV or other record types with a target to the null type, should be avoided.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4cww-f7w5-x525

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35857

Advisory: Stack consumption in trust-dns-server
IDs: CVE-2020-35857, GHSA-4cww-f7w5-x525
Record: https://patchnext.com/advisories/cve-2020-35857 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: trust-dns-server 0.18.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io trust-dns-server: affected >= 0.16.0, < 0.18.1; fixed in 0.18.1

## Suggested inspection (read-only)
- crates.io trust-dns-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on trust-dns-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4cww-f7w5-x525 (GitHub-reviewed advisory GHSA-4cww-f7w5-x525 lists affected ranges: crates.io trust-dns-server >=0.16.0 <0.18.1)

Commands are suggestions: review each one before running it.

Loading voting…