Dangling reference in access::Map with Constant
CVE-2020-35711GHSA-9pqx-g3jh-qpqq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (arc-swap 1.1.0, 0.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io arc-swap
- Affected
- >= 0.4.2, < 0.4.8>= 1.0.0, < 1.1.0
- Fixed in
- 0.4.8, 1.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pqx-g3jh-qpqq lists affected ranges: crates.io arc-swap >=0.4.2 =1.0.0 <1.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-35711: 1.62% estimated exploitation activity in the next 30 days; percentile 76.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue has been discovered in the arc-swap crate before 0.4.8 (and 1.x before 1.1.0) for Rust. Use of arcswap::access::Map with the Constant test helper (or with a user-supplied implementation of the Access trait) could sometimes lead to dangling references being returned by the map.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9pqx-g3jh-qpqq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-35711 Advisory: Dangling reference in `access::Map` with Constant IDs: CVE-2020-35711, GHSA-9pqx-g3jh-qpqq Record: https://patchnext.com/advisories/cve-2020-35711 (revision 1, source checked 26 Oct 2026, 15:33 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: arc-swap 1.1.0, 0.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io arc-swap: affected >= 0.4.2, < 0.4.8; >= 1.0.0, < 1.1.0; fixed in 0.4.8, 1.1.0 ## Suggested inspection (read-only) - crates.io arc-swap: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on arc-swap. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9pqx-g3jh-qpqq (GitHub-reviewed advisory GHSA-9pqx-g3jh-qpqq lists affected ranges: crates.io arc-swap >=0.4.2 =1.0.0 <1.1.0) Commands are suggestions: review each one before running it.
Loading voting…