Skip to content

← Actionable
High, CVSS 8.8

CakePHP allows method override parameters to bypass CSRF checks

CVE-2020-35239GHSA-9pgx-pf36-w46r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 4.1.4, 4.0.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist cakephp/cakephp

    Affected
    >= 4.0.0, < 4.0.10>= 4.1.0, < 4.1.4
    Fixed in
    4.0.10, 4.1.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-35239: 0.61% estimated exploitation activity in the next 30 days; percentile 49.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

A vulnerability exists in CakePHP versions 4.0.x through 4.1.3. The CsrfProtectionMiddleware component allows method override parameters to bypass CSRF checks by changing the HTTP request method to an arbitrary string that is not in the list of request methods that CakePHP checks. Additionally, the route middleware does not verify that this overriden method (which can be an arbitrary string) is actually an HTTP method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9pgx-pf36-w46r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-35239

Advisory: CakePHP allows method override parameters to bypass CSRF checks
IDs: CVE-2020-35239, GHSA-9pgx-pf36-w46r
Record: https://patchnext.com/advisories/cve-2020-35239 (revision 1, source checked 26 Oct 2026, 14:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 4.1.4, 4.0.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist cakephp/cakephp: affected >= 4.0.0, < 4.0.10; >= 4.1.0, < 4.1.4; fixed in 4.0.10, 4.1.4

## Suggested inspection (read-only)
- Packagist cakephp/cakephp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on cakephp/cakephp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9pgx-pf36-w46r (GitHub-reviewed advisory GHSA-9pgx-pf36-w46r lists affected ranges: Packagist cakephp/cakephp >=4.0.0 =4.1.0 <4.1.4)

Commands are suggestions: review each one before running it.

Loading voting…