Grav CMS Arbitrary File Deletion
CVE-2020-29555GHSA-gpmf-q5jh-hjx4
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getgrav/grav
- Affected
- >= 1.7.0-beta.1, <= 1.7.0-rc.17< 1.6.30
- Fixed in
- 1.6.30
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gpmf-q5jh-hjx4 lists affected ranges: Packagist getgrav/grav >=1.7.0-beta.1 =0 <1.6.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2020-29555: 2.90% estimated exploitation activity in the next 30 days; percentile 86.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The BackupDelete functionality in Grav CMS through 1.7.0-rc.17 allows an authenticated attacker to delete arbitrary files on the underlying server by exploiting a path-traversal technique. (This vulnerability can also be exploited by an unauthenticated attacker due to a lack of CSRF protection.)
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gpmf-q5jh-hjx4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-29555 Advisory: Grav CMS Arbitrary File Deletion IDs: CVE-2020-29555, GHSA-gpmf-q5jh-hjx4 Record: https://patchnext.com/advisories/cve-2020-29555 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: getgrav/grav 1.6.30. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getgrav/grav: affected >= 1.7.0-beta.1, <= 1.7.0-rc.17; < 1.6.30; fixed in 1.6.30 ## Suggested inspection (read-only) - Packagist getgrav/grav: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getgrav/grav. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gpmf-q5jh-hjx4 (GitHub-reviewed advisory GHSA-gpmf-q5jh-hjx4 lists affected ranges: Packagist getgrav/grav >=1.7.0-beta.1 =0 <1.6.30) Commands are suggestions: review each one before running it.
Loading voting…