Skip to content

← Actionable
High, CVSS 8.8

Grav CMS Cross-Site Request Forgery (CSRF)

CVE-2020-29553GHSA-fqff-vcvx-68h3

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist getgrav/grav

    Affected
    >= 1.7.0-beta.1, <= 1.7.0-rc.17< 1.6.30
    Fixed in
    1.6.30

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-29553: 1.36% estimated exploitation activity in the next 30 days; percentile 71.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Scheduler in Grav CMS through 1.7.0-rc.17 allows an attacker to execute a system command by tricking an admin into visiting a malicious website (CSRF).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fqff-vcvx-68h3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-29553

Advisory: Grav CMS Cross-Site Request Forgery (CSRF)
IDs: CVE-2020-29553, GHSA-fqff-vcvx-68h3
Record: https://patchnext.com/advisories/cve-2020-29553 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: getgrav/grav 1.6.30. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist getgrav/grav: affected >= 1.7.0-beta.1, <= 1.7.0-rc.17; < 1.6.30; fixed in 1.6.30

## Suggested inspection (read-only)
- Packagist getgrav/grav: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on getgrav/grav.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fqff-vcvx-68h3 (GitHub-reviewed advisory GHSA-fqff-vcvx-68h3 lists affected ranges: Packagist getgrav/grav >=1.7.0-beta.1 =0 <1.6.30)

Commands are suggestions: review each one before running it.

Loading voting…