Cross-site scripting in papermerge
CVE-2020-29456GHSA-9w49-m7xh-5r39
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (papermerge 1.5.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI papermerge
- Affected
- >= 1.2.0, < 1.5.2
- Fixed in
- 1.5.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9w49-m7xh-5r39 lists affected ranges: PyPI papermerge >=1.2.0 <1.5.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9w49-m7xh-5r39 lists affected ranges: PyPI papermerge >=1.2.0 <1.5.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
- EPSS
- CVE-2020-29456: 1.56% estimated exploitation activity in the next 30 days; percentile 75.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9w49-m7xh-5r39
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-9w49-m7xh-5r39
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-29456 Advisory: Cross-site scripting in papermerge IDs: CVE-2020-29456, GHSA-9w49-m7xh-5r39 Record: https://patchnext.com/advisories/cve-2020-29456 (revision 3, source checked 26 Oct 2026, 13:21 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: papermerge 1.5.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI papermerge: affected >= 1.2.0, < 1.5.2; fixed in 1.5.2 ## Suggested inspection (read-only) - `python -m pip show papermerge`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on papermerge. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-9w49-m7xh-5r39 (OSV record GHSA-9w49-m7xh-5r39 lists affected ranges: PyPI papermerge >=1.2.0 <1.5.2 (fixed)) - Verified: https://github.com/advisories/GHSA-9w49-m7xh-5r39 (GitHub-reviewed advisory GHSA-9w49-m7xh-5r39 lists affected ranges: PyPI papermerge >=1.2.0 <1.5.2) Commands are suggestions: review each one before running it.
Loading voting…