scikit-learn Denial of Service
CVE-2020-28975GHSA-jxfp-4rvq-9h9m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (scikit-learn 1.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI scikit-learn
- Affected
- >= 0.23.2, < 1.0.1
- Fixed in
- 1.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jxfp-4rvq-9h9m lists affected ranges: PyPI scikit-learn >=0.23.2 <1.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jxfp-4rvq-9h9m lists affected ranges: PyPI scikit-learn >=0.23.2 <1.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-28975: 3.50% estimated exploitation activity in the next 30 days; percentile 89.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
svmpredictvalues in svm.cpp in Libsvm v324, as used in scikit-learn 0.23.2 and other products, allows attackers to cause a denial of service (segmentation fault) via a crafted model SVM (introduced via pickle, json, or any other model permanence standard) with a large value in the nsupport array. NOTE: the scikit-learn vendor's position is that the behavior can only occur if the library's API is violated by an application that changes a private attribute.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jxfp-4rvq-9h9m
- Revision 1 · created ·
Published from osv record GHSA-jxfp-4rvq-9h9m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-28975 Advisory: scikit-learn Denial of Service IDs: CVE-2020-28975, GHSA-jxfp-4rvq-9h9m Record: https://patchnext.com/advisories/cve-2020-28975 (revision 2, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: scikit-learn 1.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI scikit-learn: affected >= 0.23.2, < 1.0.1; fixed in 1.0.1 ## Suggested inspection (read-only) - `python -m pip show scikit-learn`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on scikit-learn. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jxfp-4rvq-9h9m (OSV record GHSA-jxfp-4rvq-9h9m lists affected ranges: PyPI scikit-learn >=0.23.2 <1.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-jxfp-4rvq-9h9m (GitHub-reviewed advisory GHSA-jxfp-4rvq-9h9m lists affected ranges: PyPI scikit-learn >=0.23.2 <1.0.1) Commands are suggestions: review each one before running it.
Loading voting…