Insufficiently Protected Credentials in PowerJob
CVE-2020-28865GHSA-w4q4-jcm7-g4m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (com.github.kfcfans:powerjob 3.3.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven com.github.kfcfans:powerjob
- Affected
- < 3.3.3
- Fixed in
- 3.3.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-w4q4-jcm7-g4m6 lists affected ranges: Maven com.github.kfcfans:powerjob >=0 <3.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2020-28865: 0.80% estimated exploitation activity in the next 30 days; percentile 56.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An issue was discovered in PowerJob through 3.2.2, allows attackers to change arbitrary user passwords via the id parameter to /appinfo/save.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-w4q4-jcm7-g4m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-28865 Advisory: Insufficiently Protected Credentials in PowerJob IDs: CVE-2020-28865, GHSA-w4q4-jcm7-g4m6 Record: https://patchnext.com/advisories/cve-2020-28865 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: com.github.kfcfans:powerjob 3.3.3. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven com.github.kfcfans:powerjob: affected < 3.3.3; fixed in 3.3.3 ## Suggested inspection (read-only) - Maven com.github.kfcfans:powerjob: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on com.github.kfcfans:powerjob. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-w4q4-jcm7-g4m6 (GitHub-reviewed advisory GHSA-w4q4-jcm7-g4m6 lists affected ranges: Maven com.github.kfcfans:powerjob >=0 <3.3.3) Commands are suggestions: review each one before running it.
Loading voting…