xmlhttprequest and xmlhttprequest-ssl vulnerable to Arbitrary Code Injection
CVE-2020-28502GHSA-h4j5-c7cj-74xg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (xmlhttprequest-ssl 1.6.2; xmlhttprequest 1.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.6.2
- Fixed in
- 1.6.2
npm xmlhttprequest
- Affected
- < 1.7.0
- Fixed in
- 1.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-h4j5-c7cj-74xg lists affected ranges: npm xmlhttprequest >=0 =0 <1.6.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h4j5-c7cj-74xg lists affected ranges: npm xmlhttprequest >=0 =0 <1.6.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-28502: 4.63% estimated exploitation activity in the next 30 days; percentile 91.72 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package xmlhttprequest before 1.7.0; all versions of package xmlhttprequest-ssl. Provided requests are sent synchronously (async=False on xhr.open), malicious user input flowing into xhr.send could result in arbitrary code being injected and run.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-h4j5-c7cj-74xg
- Revision 1 · created ·
Published from osv record GHSA-h4j5-c7cj-74xg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-28502 Advisory: xmlhttprequest and xmlhttprequest-ssl vulnerable to Arbitrary Code Injection IDs: CVE-2020-28502, GHSA-h4j5-c7cj-74xg Record: https://patchnext.com/advisories/cve-2020-28502 (revision 2, source checked 26 Oct 2026, 12:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: xmlhttprequest-ssl 1.6.2; xmlhttprequest 1.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm xmlhttprequest-ssl: affected < 1.6.2; fixed in 1.6.2 - npm xmlhttprequest: affected < 1.7.0; fixed in 1.7.0 ## Suggested inspection (read-only) - `npm ls xmlhttprequest-ssl --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls xmlhttprequest --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on xmlhttprequest-ssl, xmlhttprequest. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-h4j5-c7cj-74xg (OSV record GHSA-h4j5-c7cj-74xg lists affected ranges: npm xmlhttprequest >=0 =0 <1.6.2 (fixed)) - Verified: https://github.com/advisories/GHSA-h4j5-c7cj-74xg (GitHub-reviewed advisory GHSA-h4j5-c7cj-74xg lists affected ranges: npm xmlhttprequest >=0 =0 <1.6.2) Commands are suggestions: review each one before running it.
Loading voting…