Skip to content

← Actionable
Medium, CVSS 5.3amended

Regular Expression Denial of Service (ReDoS) in lodash

CVE-2020-28500GHSA-29mw-wpgm-hmr9

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm lodash.trim

    Affected
    >= 4.0.0, <= 4.5.1
    Fixed in
    no fixed version recorded
  • RubyGems lodash-rails

    Affected
    >= 4.0.0, < 4.17.21
    Fixed in
    4.17.21
  • npm lodash-es

    Affected
    >= 4.0.0, < 4.17.21
    Fixed in
    4.17.21
  • npm lodash

    Affected
    >= 4.0.0, < 4.17.21
    Fixed in
    4.17.21
  • npm lodash.trimend

    Affected
    >= 4.0.0, <= 4.5.1
    Fixed in
    no fixed version recorded

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2020-28500: 7.34% estimated exploitation activity in the next 30 days; percentile 94.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

All versions of package lodash prior to 4.17.21 are vulnerable to Regular Expression Denial of Service (ReDoS) via the toNumber, trim and trimEnd functions. Steps to reproduce (provided by reporter Liyuan Chen):

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-29mw-wpgm-hmr9

  2. Revision 1 · created ·

    Published from osv record GHSA-29mw-wpgm-hmr9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-28500

Advisory: Regular Expression Denial of Service (ReDoS) in lodash
IDs: CVE-2020-28500, GHSA-29mw-wpgm-hmr9
Record: https://patchnext.com/advisories/cve-2020-28500 (revision 2, source checked 26 Oct 2026, 12:38 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: lodash-rails 4.17.21; lodash-es 4.17.21; lodash 4.17.21. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm lodash.trim: affected >= 4.0.0, <= 4.5.1
- RubyGems lodash-rails: affected >= 4.0.0, < 4.17.21; fixed in 4.17.21
- npm lodash-es: affected >= 4.0.0, < 4.17.21; fixed in 4.17.21
- npm lodash: affected >= 4.0.0, < 4.17.21; fixed in 4.17.21
- npm lodash.trimend: affected >= 4.0.0, <= 4.5.1

## Suggested inspection (read-only)
- `npm ls lodash.trim --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- RubyGems lodash-rails: check the installed version with your package manager.
- `npm ls lodash-es --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls lodash.trimend --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on lodash.trim, lodash-rails, lodash-es, lodash, lodash.trimend.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-29mw-wpgm-hmr9 (OSV record GHSA-29mw-wpgm-hmr9 lists affected ranges: npm lodash >=4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.17.21 (fixed))
- Verified: https://github.com/advisories/GHSA-29mw-wpgm-hmr9 (GitHub-reviewed advisory GHSA-29mw-wpgm-hmr9 lists affected ranges: npm lodash >=4.0.0 =4.0.0 =4.0.0 =4.0.0 =4.0.0 <4.17.21)

Commands are suggestions: review each one before running it.

Loading voting…