Skip to content

← Actionable
Medium, CVSS 6.8amended

Elliptic Uses a Broken or Risky Cryptographic Algorithm

CVE-2020-28498GHSA-r9p9-mrjm-926w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (elliptic 6.5.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm elliptic

    Affected
    < 6.5.4
    Fixed in
    6.5.4

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
EPSS
  • CVE-2020-28498: 1.25% estimated exploitation activity in the next 30 days; percentile 69.43 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The npm package elliptic before version 6.5.4 are vulnerable to Cryptographic Issues via the secp256k1 implementation in elliptic/ec/key.js. There is no check to confirm that the public key point passed into the derive function actually exists on the secp256k1 curve. This results in the potential for the private key used in this implementation to be revealed after a number of ECDH operations are performed.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-r9p9-mrjm-926w

  2. Revision 1 · created ·

    Published from osv record GHSA-r9p9-mrjm-926w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-28498

Advisory: Elliptic Uses a Broken or Risky Cryptographic Algorithm
IDs: CVE-2020-28498, GHSA-r9p9-mrjm-926w
Record: https://patchnext.com/advisories/cve-2020-28498 (revision 2, source checked 26 Oct 2026, 12:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: elliptic 6.5.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm elliptic: affected < 6.5.4; fixed in 6.5.4

## Suggested inspection (read-only)
- `npm ls elliptic --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on elliptic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-r9p9-mrjm-926w (OSV record GHSA-r9p9-mrjm-926w lists affected ranges: npm elliptic >=0 <6.5.4 (fixed))
- Verified: https://github.com/advisories/GHSA-r9p9-mrjm-926w (GitHub-reviewed advisory GHSA-r9p9-mrjm-926w lists affected ranges: npm elliptic >=0 <6.5.4)

Commands are suggestions: review each one before running it.

Loading voting…