Denial of service in three
CVE-2020-28496GHSA-fq6p-x6j3-cmmq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (three 0.125.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm three
- Affected
- < 0.125.0
- Fixed in
- 0.125.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-fq6p-x6j3-cmmq lists affected ranges: npm three >=0 <0.125.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-fq6p-x6j3-cmmq lists affected ranges: npm three >=0 <0.125.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-28496: 2.52% estimated exploitation activity in the next 30 days; percentile 84.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
This affects the package three before 0.125.0. This can happen when handling rgb or hsl colors. PoC:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-fq6p-x6j3-cmmq
- Revision 1 · created ·
Published from osv record GHSA-fq6p-x6j3-cmmq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-28496 Advisory: Denial of service in three IDs: CVE-2020-28496, GHSA-fq6p-x6j3-cmmq Record: https://patchnext.com/advisories/cve-2020-28496 (revision 2, source checked 26 Oct 2026, 12:25 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: three 0.125.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm three: affected < 0.125.0; fixed in 0.125.0 ## Suggested inspection (read-only) - `npm ls three --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on three. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-fq6p-x6j3-cmmq (OSV record GHSA-fq6p-x6j3-cmmq lists affected ranges: npm three >=0 <0.125.0 (fixed)) - Verified: https://github.com/advisories/GHSA-fq6p-x6j3-cmmq (GitHub-reviewed advisory GHSA-fq6p-x6j3-cmmq lists affected ranges: npm three >=0 <0.125.0) Commands are suggestions: review each one before running it.
Loading voting…