Skip to content

← Actionable
Medium, CVSS 6.5

Path Traversal in HashiCorp Nomad

CVE-2020-28348GHSA-5x92-p4p5-33c4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/nomad 0.12.8, 0.11.7, 0.10.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/hashicorp/nomad

    Affected
    >= 0.9.0, < 0.10.8>= 0.11.0-beta1, < 0.11.7>= 0.12.0-beta1, < 0.12.8
    Fixed in
    0.11.7, 0.12.8, 0.10.8

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2020-28348: 1.65% estimated exploitation activity in the next 30 days; percentile 76.55 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

HashiCorp Nomad and Nomad Enterprise 0.9.0 up to 0.12.7 client Docker file sandbox feature (github.com/hashicorp/nomad/drivers/docker) may be subverted when not explicitly disabled or when using a volume mount type. Fixed in 0.12.8, 0.11.7, and 0.10.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-5x92-p4p5-33c4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-28348

Advisory: Path Traversal in HashiCorp Nomad
IDs: CVE-2020-28348, GHSA-5x92-p4p5-33c4
Record: https://patchnext.com/advisories/cve-2020-28348 (revision 1, source checked 26 Oct 2026, 14:59 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/nomad 0.12.8, 0.11.7, 0.10.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/hashicorp/nomad: affected >= 0.9.0, < 0.10.8; >= 0.11.0-beta1, < 0.11.7; >= 0.12.0-beta1, < 0.12.8; fixed in 0.11.7, 0.12.8, 0.10.8

## Suggested inspection (read-only)
- Go github.com/hashicorp/nomad: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/hashicorp/nomad.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-5x92-p4p5-33c4 (GitHub-reviewed advisory GHSA-5x92-p4p5-33c4 lists affected ranges: Go github.com/hashicorp/nomad >=0.9.0 =0.11.0-beta1 =0.12.0-beta1 <0.12.8)

Commands are suggestions: review each one before running it.

Loading voting…