Skip to content

← Actionable
Critical, CVSS 9.8amended

flattenizer vulnerable to prototype pollution

CVE-2020-28279GHSA-vq33-26pr-r4h6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (flattenizer 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-28279: 3.11% estimated exploitation activity in the next 30 days; percentile 87.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Overview Prototype pollution vulnerability in ‘flattenizer’ versions 0.0.5 through 1.0.5 allows an attacker to cause a denial of service and may lead to remote code execution. Details The NPM module 'flattenizer' can be abused by Prototype Pollution vulnerability since the function 'unflatten()' did not check for the type of object before assigning value to the property. Due to this flaw an attacker could create a non-existent property or able to manipulate the property which leads to Denial of Service or potentially Remote code execution. PoC Details There is no validation before assigning the property to check whether the assigned argument is the Object's own property or not, the property polluted will be directly be assigned thereby polluting the Object prototype. Later in the code, if there is a check to validate polluted the valued would be substituted as "true" as it had been polluted.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-vq33-26pr-r4h6

  2. Revision 1 · created ·

    Published from osv record GHSA-vq33-26pr-r4h6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-28279

Advisory: flattenizer vulnerable to prototype pollution
IDs: CVE-2020-28279, GHSA-vq33-26pr-r4h6
Record: https://patchnext.com/advisories/cve-2020-28279 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: flattenizer 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flattenizer: affected >= 0.0.5, <= 1.0.5; fixed in 1.1.1

## Suggested inspection (read-only)
- `npm ls flattenizer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flattenizer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vq33-26pr-r4h6 (OSV record GHSA-vq33-26pr-r4h6 lists affected ranges: npm flattenizer >=0.0.5 <1.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vq33-26pr-r4h6 (GitHub-reviewed advisory GHSA-vq33-26pr-r4h6 lists affected ranges: npm flattenizer >=0.0.5 <=1.0.5)

Commands are suggestions: review each one before running it.

Loading voting…