Skip to content

← Actionable
Medium, CVSS 5.3

DOS vulnerability for Quoted Quality CSV headers

CVE-2020-27223GHSA-m394-8rww-3jr7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.eclipse.jetty:jetty-server 11.0.1, 10.0.1, 9.4.37), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2020-27223: 78.03% estimated exploitation activity in the next 30 days; percentile 99.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact When Jetty handles a request containing request headers with a large number of “quality” (i.e. q) parameters (such as what are seen on the Accept, Accept-Encoding, and Accept-Language request headers), the server may enter a denial of service (DoS) state due to high CPU usage while sorting the list of values based on their quality values. A single request can easily consume minutes of CPU time before it is even dispatched to the application. The only features within Jetty that can trigger this behavior are: - Default Error Handling - the Accept request header with the QuotedQualityCSV is used to determine what kind of content to send back to the client (html, text, json, xml, etc) - StatisticsServlet - uses the Accept request header with the QuotedQualityCSV to determine what kind of content to send back to the client (xml, json, text, html, etc) - HttpServletRequest.getLocale() - uses the Accept-Language request header with the QuotedQualityCSV to determine which “preferred”…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m394-8rww-3jr7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-27223

Advisory: DOS vulnerability for Quoted Quality CSV headers
IDs: CVE-2020-27223, GHSA-m394-8rww-3jr7
Record: https://patchnext.com/advisories/cve-2020-27223 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.eclipse.jetty:jetty-server 11.0.1, 10.0.1, 9.4.37. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.eclipse.jetty:jetty-server: affected >= 9.4.6, < 9.4.37; >= 10.0.0, <= 10.0.0; >= 11.0.0, <= 11.0.0; fixed in 11.0.1, 10.0.1, 9.4.37

## Suggested inspection (read-only)
- Maven org.eclipse.jetty:jetty-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.eclipse.jetty:jetty-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m394-8rww-3jr7 (GitHub-reviewed advisory GHSA-m394-8rww-3jr7 lists affected ranges: Maven org.eclipse.jetty:jetty-server >=9.4.6 =10.0.0 =11.0.0 <=11.0.0)

Commands are suggestions: review each one before running it.

Loading voting…