Skip to content

← Actionable
High, CVSS 7.5

Improper Authentication in Apereo CAS

CVE-2020-27178GHSA-q39c-5vh5-vw2p

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apereo.cas:cas-server-support-otp-mfa-core 6.2.4, 6.1.7.2, 5.3.16; org.apereo.cas:cas-server-webapp 6.2.4, 6.1.7.2, 5.3.16), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-q39c-5vh5-vw2p lists affected ranges: Maven org.apereo.cas:cas-server-webapp >=5.3.0 =6.0.0 =6.2.0 =5.3.0 =6.0.0 =6.2.0 <6.2.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-27178: 1.22% estimated exploitation activity in the next 30 days; percentile 68.69 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apereo CAS 5.3.x before 5.3.16, 6.x before 6.1.7.2, 6.2.x before 6.2.4, and 6.3.x before 6.3.0-RC4 mishandles secret keys with Google Authenticator for multifactor authentication.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q39c-5vh5-vw2p

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-27178

Advisory: Improper Authentication in Apereo CAS
IDs: CVE-2020-27178, GHSA-q39c-5vh5-vw2p
Record: https://patchnext.com/advisories/cve-2020-27178 (revision 1, source checked 26 Oct 2026, 16:06 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apereo.cas:cas-server-support-otp-mfa-core 6.2.4, 6.1.7.2, 5.3.16; org.apereo.cas:cas-server-webapp 6.2.4, 6.1.7.2, 5.3.16. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apereo.cas:cas-server-support-otp-mfa-core: affected >= 5.3.0, < 5.3.16; >= 6.0.0, <= 6.1.7.1; >= 6.2.0, < 6.2.4; fixed in 5.3.16, 6.2.4, 6.1.7.2
- Maven org.apereo.cas:cas-server-webapp: affected >= 5.3.0, < 5.3.16; >= 6.0.0, <= 6.1.7.1; >= 6.2.0, < 6.2.4; fixed in 5.3.16, 6.2.4, 6.1.7.2

## Suggested inspection (read-only)
- Maven org.apereo.cas:cas-server-support-otp-mfa-core: check the installed version with your package manager.
- Maven org.apereo.cas:cas-server-webapp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apereo.cas:cas-server-support-otp-mfa-core, org.apereo.cas:cas-server-webapp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q39c-5vh5-vw2p (GitHub-reviewed advisory GHSA-q39c-5vh5-vw2p lists affected ranges: Maven org.apereo.cas:cas-server-webapp >=5.3.0 =6.0.0 =6.2.0 =5.3.0 =6.0.0 =6.2.0 <6.2.4)

Commands are suggestions: review each one before running it.

Loading voting…