Skip to content

← Actionable
Medium, CVSS 5.1amended

Cross-site scripting (XSS) vulnerability in the fallback authentication endpoint

CVE-2020-26891GHSA-3x8c-fmpc-5rmq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.21.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2020-26891: 1.92% estimated exploitation activity in the next 30 days; percentile 79.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact The fallback authentication endpoint served via Synapse was vulnerable to cross-site scripting (XSS) attacks. The impact depends on the configuration of the domain that Synapse is deployed on, but may allow access to cookies and other browser data, CSRF vulnerabilities, and access to other resources served on the same domain or parent domains. Patches This is fixed by #8444, which is included in Synapse v1.21.0. Workarounds If the homeserver is not configured to use reCAPTCHA, consent (terms of service), or single sign-on then the affected endpoint can be blocked at a reverse proxy: /matrix/client/r0/auth/./fallback/web /matrix/client/unstable/auth/./fallback/web

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-3x8c-fmpc-5rmq

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-3x8c-fmpc-5rmq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26891

Advisory: Cross-site scripting (XSS) vulnerability in the fallback authentication endpoint
IDs: CVE-2020-26891, GHSA-3x8c-fmpc-5rmq
Record: https://patchnext.com/advisories/cve-2020-26891 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.21.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.21.0; fixed in 1.21.0

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3x8c-fmpc-5rmq (OSV record GHSA-3x8c-fmpc-5rmq lists affected ranges: PyPI matrix-synapse >=0 <1.21.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3x8c-fmpc-5rmq (GitHub-reviewed advisory GHSA-3x8c-fmpc-5rmq lists affected ranges: PyPI matrix-synapse >=0 <1.21.0)

Commands are suggestions: review each one before running it.

Loading voting…