Skip to content

← Actionable
High, CVSS 8.7amended

Denial of service attack due to invalid JSON

CVE-2020-26890GHSA-4mp3-385r-v63f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.20.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-26890: 3.00% estimated exploitation activity in the next 30 days; percentile 87.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A denial of service attack against Matrix clients can be exploited by sending an event including invalid JSON data to Synapse. Synapse would relay the data to clients which could crash or hang. Impact is long-lasting if the event is made part of the room state. Patches At a minimum #8106 and #8291 must be applied. #7372 and #8124 include additional checks. Workarounds There are no known workarounds. Upgrading notes If an invalid event is accepted by an earlier Synapse it can become part of the room state and will not be fixed by upgrading Synapse. Redacting the invalid event should avoid clients receiving the invalid event.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-4mp3-385r-v63f

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-4mp3-385r-v63f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26890

Advisory: Denial of service attack due to invalid JSON
IDs: CVE-2020-26890, GHSA-4mp3-385r-v63f
Record: https://patchnext.com/advisories/cve-2020-26890 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.20.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.20.0; fixed in 1.20.0

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4mp3-385r-v63f (OSV record GHSA-4mp3-385r-v63f lists affected ranges: PyPI matrix-synapse >=0 <1.20.0 (fixed))
- Verified: https://github.com/advisories/GHSA-4mp3-385r-v63f (GitHub-reviewed advisory GHSA-4mp3-385r-v63f lists affected ranges: PyPI matrix-synapse >=0 <1.20.0)

Commands are suggestions: review each one before running it.

Loading voting…