Skip to content

← Actionable
Unratedamended

File System Bounds Escape

CVE-2020-26299GHSA-pmw4-jgxx-pcq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ftp-srv 4.4.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm ftp-srv

    Affected
    < 4.4.0
    Fixed in
    4.4.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2020-26299: 1.86% estimated exploitation activity in the next 30 days; percentile 79.30 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Clients of FTP servers utilizing ftp-srv hosted on Windows machines can escape the FTP user's defined root folder using the expected FTP commands, for example, CWD and UPDR. Background When windows separators exist within the path (\), path.resolve leaves the upper pointers intact and allows the user to move beyond the root folder defined for that user. We did not take that into account when creating the path resolve function. Patches None at the moment. Workarounds There are no workarounds for windows servers. Hosting the server on a different OS mitigates the issue. References Issues: https://github.com/autovance/ftp-srv/issues/167 https://github.com/autovance/ftp-srv/issues/225 For more information If you have any questions or comments about this advisory: Open an issue at https://github.com/autovance/ftp-srv. Please email us directly; security@autovance.com.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pmw4-jgxx-pcq9

  2. Revision 1 · created ·

    Published from osv record GHSA-pmw4-jgxx-pcq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26299

Advisory: File System Bounds Escape
IDs: CVE-2020-26299, GHSA-pmw4-jgxx-pcq9
Record: https://patchnext.com/advisories/cve-2020-26299 (revision 2, source checked 26 Oct 2026, 12:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ftp-srv 4.4.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm ftp-srv: affected < 4.4.0; fixed in 4.4.0

## Suggested inspection (read-only)
- `npm ls ftp-srv --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ftp-srv.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pmw4-jgxx-pcq9 (OSV record GHSA-pmw4-jgxx-pcq9 lists affected ranges: npm ftp-srv >=0 <4.4.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pmw4-jgxx-pcq9 (GitHub-reviewed advisory GHSA-pmw4-jgxx-pcq9 lists affected ranges: npm ftp-srv >=0 <4.4.0)

Commands are suggestions: review each one before running it.

Loading voting…