Injection/XSS in Redcarpet
CVE-2020-26298GHSA-q3wr-qw3g-3p4h
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redcarpet 3.5.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems redcarpet
- Affected
- < 3.5.1
- Fixed in
- 3.5.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3wr-qw3g-3p4h lists affected ranges: RubyGems redcarpet >=0 <3.5.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:H/A:N
- EPSS
- CVE-2020-26298: 1.59% estimated exploitation activity in the next 30 days; percentile 75.67 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Redcarpet is a Ruby library for Markdown processing. In Redcarpet before version 3.5.1, there is an injection vulnerability which can enable a cross-site scripting attack. In affected versions no HTML escaping was being performed when processing quotes. This applies even when the :escapehtml option was being used. This is fixed in version 3.5.1 by the referenced commit.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q3wr-qw3g-3p4h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26298 Advisory: Injection/XSS in Redcarpet IDs: CVE-2020-26298, GHSA-q3wr-qw3g-3p4h Record: https://patchnext.com/advisories/cve-2020-26298 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redcarpet 3.5.1. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems redcarpet: affected < 3.5.1; fixed in 3.5.1 ## Suggested inspection (read-only) - RubyGems redcarpet: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redcarpet. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q3wr-qw3g-3p4h (GitHub-reviewed advisory GHSA-q3wr-qw3g-3p4h lists affected ranges: RubyGems redcarpet >=0 <3.5.1) Commands are suggestions: review each one before running it.
Loading voting…