Skip to content

← Actionable
Unrated

SAML authentication vulnerability due to stdlib XML parsing

CVE-2020-26276GHSA-w3wf-cfx3-6gcx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fleetdm/fleet/v4 3.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2020-26276: 2.20% estimated exploitation activity in the next 30 days; percentile 82.49 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Due to issues in Go's standard library XML parsing, a valid SAML response may be mutated by an attacker to modify the trusted document. This can result in allowing unverified logins from a SAML IdP. Users that configure Fleet with SSO login may be vulnerable to this issue. Patches This issue is patched in 3.5.1 using https://github.com/mattermost/xml-roundtrip-validator. Workarounds If upgrade to 3.5.1 is not possible, users should disable SSO authentication in Fleet. References See https://mattermost.com/blog/coordinated-disclosure-go-xml-vulnerabilities/ for more information about the underlying vulnerabilities. For more information If you have any questions or comments about this advisory: Email us at security@fleetdm.com Join #fleet in osquery Slack

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-w3wf-cfx3-6gcx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26276

Advisory: SAML authentication vulnerability due to stdlib XML parsing
IDs: CVE-2020-26276, GHSA-w3wf-cfx3-6gcx
Record: https://patchnext.com/advisories/cve-2020-26276 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/fleetdm/fleet/v4 3.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/fleetdm/fleet/v4: affected < 3.5.1; fixed in 3.5.1

## Suggested inspection (read-only)
- Go github.com/fleetdm/fleet/v4: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/fleetdm/fleet/v4.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-w3wf-cfx3-6gcx (GitHub-reviewed advisory GHSA-w3wf-cfx3-6gcx lists affected ranges: Go github.com/fleetdm/fleet/v4 >=0 <3.5.1)

Commands are suggestions: review each one before running it.

Loading voting…