Skip to content

← Actionable
Medium, CVSS 5.3amended

Jupyter Server open redirect vulnerability

CVE-2020-26275GHSA-9f66-54xg-pc2c

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 1.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N · score source
EPSS
  • CVE-2020-26275: 1.37% estimated exploitation activity in the next 30 days; percentile 72.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What kind of vulnerability is it? Who is impacted? Open redirect vulnerability - a maliciously crafted link to a jupyter server could redirect the browser to a different website. All jupyter servers running without a baseurl prefix are technically affected, however, these maliciously crafted links can only be reasonably made for known jupyter server hosts. A link to your jupyter server may appear safe, but ultimately redirect to a spoofed server on the public internet. This same vulnerability was patched in upstream notebook v5.7.8. Patches Has the problem been patched? What versions should users upgrade to? Patched in jupyterserver 1.1.1. If upgrade is not available, a workaround can be to run your server on a url prefix: References OWASP page on open redirects For more information If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list security@ipython.org. Credit: Yaniv Nizry from CxSCA group at Checkmarx

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-9f66-54xg-pc2c

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-9f66-54xg-pc2c

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26275

Advisory: Jupyter Server open redirect vulnerability
IDs: CVE-2020-26275, GHSA-9f66-54xg-pc2c
Record: https://patchnext.com/advisories/cve-2020-26275 (revision 3, source checked 26 Oct 2026, 13:41 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jupyter-server 1.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI jupyter-server: affected < 1.1.1; fixed in 1.1.1

## Suggested inspection (read-only)
- `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jupyter-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-9f66-54xg-pc2c (OSV record GHSA-9f66-54xg-pc2c lists affected ranges: PyPI jupyter-server >=0 <1.1.1 (fixed))
- Verified: https://github.com/advisories/GHSA-9f66-54xg-pc2c (GitHub-reviewed advisory GHSA-9f66-54xg-pc2c lists affected ranges: PyPI jupyter-server >=0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…