Command Injection Vulnerability in systeminformation
CVE-2020-26274GHSA-m57p-p67h-mq74
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (systeminformation 4.31.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 4.31.1
- Fixed in
- 4.31.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-m57p-p67h-mq74 lists affected ranges: npm systeminformation >=0 <4.31.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-m57p-p67h-mq74 lists affected ranges: npm systeminformation >=0 <4.31.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.4 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-26274: 2.74% estimated exploitation activity in the next 30 days; percentile 86.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact command injection vulnerability Patches Problem was fixed with a shell string sanitation fix. Please upgrade to version = 4.31.1 Workarounds If you cannot upgrade, be sure to check or sanitize service parameter strings that are passed to si.inetLatency() For more information If you have any questions or comments about this advisory: Open an issue in systeminformation
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-m57p-p67h-mq74
- Revision 1 · created ·
Published from osv record GHSA-m57p-p67h-mq74
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26274 Advisory: Command Injection Vulnerability in systeminformation IDs: CVE-2020-26274, GHSA-m57p-p67h-mq74 Record: https://patchnext.com/advisories/cve-2020-26274 (revision 2, source checked 26 Oct 2026, 12:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: systeminformation 4.31.1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm systeminformation: affected < 4.31.1; fixed in 4.31.1 ## Suggested inspection (read-only) - `npm ls systeminformation --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on systeminformation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-m57p-p67h-mq74 (OSV record GHSA-m57p-p67h-mq74 lists affected ranges: npm systeminformation >=0 <4.31.1 (fixed)) - Verified: https://github.com/advisories/GHSA-m57p-p67h-mq74 (GitHub-reviewed advisory GHSA-m57p-p67h-mq74 lists affected ranges: npm systeminformation >=0 <4.31.1) Commands are suggestions: review each one before running it.
Loading voting…