user-readable api tokens in systemd units for JupyterHub
CVE-2020-26261GHSA-cg54-gpgr-4rm6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyterhub-systemdspawner 0.15.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyterhub-systemdspawner
- Affected
- < 0.15.0
- Fixed in
- 0.15.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-cg54-gpgr-4rm6 lists affected ranges: PyPI jupyterhub-systemdspawner >=0 <0.15.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-cg54-gpgr-4rm6 lists affected ranges: PyPI jupyterhub-systemdspawner >=0 <0.15.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N/E:U · score source
- EPSS
- CVE-2020-26261: 0.48% estimated exploitation activity in the next 30 days; percentile 41.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact user API tokens issued to single-user servers are specified in the environment of systemd units, which are accessible to all users. In particular, the-littlest-jupyterhub is affected, which uses systemdspawner by default. Patches Patched in jupyterhub-systemdspawner v0.15 Workarounds No workaround other than upgrading systemdspawner to 0.15 For more information If you have any questions or comments about this advisory: Open a thread in the Jupyter forum Email us at security@ipython.org
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-cg54-gpgr-4rm6
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-cg54-gpgr-4rm6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26261 Advisory: user-readable api tokens in systemd units for JupyterHub IDs: CVE-2020-26261, GHSA-cg54-gpgr-4rm6 Record: https://patchnext.com/advisories/cve-2020-26261 (revision 3, source checked 26 Oct 2026, 13:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyterhub-systemdspawner 0.15.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyterhub-systemdspawner: affected < 0.15.0; fixed in 0.15.0 ## Suggested inspection (read-only) - `python -m pip show jupyterhub-systemdspawner`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyterhub-systemdspawner. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-cg54-gpgr-4rm6 (OSV record GHSA-cg54-gpgr-4rm6 lists affected ranges: PyPI jupyterhub-systemdspawner >=0 <0.15.0 (fixed)) - Verified: https://github.com/advisories/GHSA-cg54-gpgr-4rm6 (GitHub-reviewed advisory GHSA-cg54-gpgr-4rm6 lists affected ranges: PyPI jupyterhub-systemdspawner >=0 <0.15.0) Commands are suggestions: review each one before running it.
Loading voting…