Skip to content

← Actionable
High, CVSS 7.1amended

Denial of service attack via incorrect parameters in Matrix Synapse

CVE-2020-26257GHSA-hxmp-pqch-c8mm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (matrix-synapse 1.23.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-26257: 2.39% estimated exploitation activity in the next 30 days; percentile 83.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A malicious or poorly-implemented homeserver can inject malformed events into a room by specifying a different room id in the path of a /sendjoin, /sendleave, /invite or /exchangethirdpartyinvite request. This can lead to a denial of service in which future events will not be correctly sent to other servers over federation. This affects any server which accepts federation requests from untrusted servers. Patches Issue is resolved by https://github.com/matrix-org/synapse/pull/8776. Workarounds Homeserver administrators could limit access to the federation API to trusted servers (for example via federationdomainwhitelist).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-hxmp-pqch-c8mm

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-hxmp-pqch-c8mm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26257

Advisory: Denial of service attack via incorrect parameters in Matrix Synapse
IDs: CVE-2020-26257, GHSA-hxmp-pqch-c8mm
Record: https://patchnext.com/advisories/cve-2020-26257 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: matrix-synapse 1.23.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI matrix-synapse: affected < 1.23.1; fixed in 1.23.1

## Suggested inspection (read-only)
- `python -m pip show matrix-synapse`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on matrix-synapse.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hxmp-pqch-c8mm (OSV record GHSA-hxmp-pqch-c8mm lists affected ranges: PyPI matrix-synapse >=0 <1.23.1 (fixed))
- Verified: https://github.com/advisories/GHSA-hxmp-pqch-c8mm (GitHub-reviewed advisory GHSA-hxmp-pqch-c8mm lists affected ranges: PyPI matrix-synapse >=0 <1.23.1)

Commands are suggestions: review each one before running it.

Loading voting…