Kirby Panel users could upload PHP Phar archives as content files before v2.5.14 and v3.4.5
CVE-2020-26255GHSA-g3h8-cg9x-47qw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (getkirby/panel 2.5.14; getkirby/cms 3.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist getkirby/panel
- Affected
- < 2.5.14
- Fixed in
- 2.5.14
Packagist getkirby/cms
- Affected
- >= 3.0.0, < 3.4.5
- Fixed in
- 3.4.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-g3h8-cg9x-47qw lists affected ranges: Packagist getkirby/panel >=0 =3.0.0 <3.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:N/I:H/A:N
- EPSS
- CVE-2020-26255: 1.49% estimated exploitation activity in the next 30 days; percentile 74.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact An editor with full access to the Kirby Panel can upload a PHP .phar file and execute it on the server. This vulnerability is critical if you might have potential attackers in your group of authenticated Panel users, as they can gain access to the server with such a Phar file. Visitors without Panel access cannot use this attack vector. Patches The problem has been patched in Kirby 2.5.14 and Kirby 3.4.5. Please update to one of these or a later version to fix the vulnerability. Note: Kirby 2 reaches end of life on December 31, 2020. We therefore recommend to upgrade your Kirby 2 sites to Kirby 3. If you cannot upgrade, we still recommend to update to Kirby 2.5.14. Workarounds Kirby 2 sites on older releases can also be patched by applying the changes from this commit. Credits Thanks to Thore Imhof of Accenture for reporting the problem.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-g3h8-cg9x-47qw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26255 Advisory: Kirby Panel users could upload PHP Phar archives as content files before v2.5.14 and v3.4.5 IDs: CVE-2020-26255, GHSA-g3h8-cg9x-47qw Record: https://patchnext.com/advisories/cve-2020-26255 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: getkirby/panel 2.5.14; getkirby/cms 3.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist getkirby/panel: affected < 2.5.14; fixed in 2.5.14 - Packagist getkirby/cms: affected >= 3.0.0, < 3.4.5; fixed in 3.4.5 ## Suggested inspection (read-only) - Packagist getkirby/panel: check the installed version with your package manager. - Packagist getkirby/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on getkirby/panel, getkirby/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-g3h8-cg9x-47qw (GitHub-reviewed advisory GHSA-g3h8-cg9x-47qw lists affected ranges: Packagist getkirby/panel >=0 =3.0.0 <3.4.5) Commands are suggestions: review each one before running it.
Loading voting…