Skip to content

← Actionable
High, CVSS 8.3amended

Base class whitelist configuration ignored in OAuthenticator

CVE-2020-26250GHSA-384w-5v3f-q499

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (oauthenticator 0.12.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N · score source
EPSS
  • CVE-2020-26250: 1.13% estimated exploitation activity in the next 30 days; percentile 66.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact What goes wrong? The deprecated (in jupyterhub 1.2) configuration Authenticator.whitelist, which should be transparently mapped to Authenticator.allowedusers with a warning, is instead ignored by OAuthenticator classes, resulting in the same behavior as if this configuration has not been set. If this is the only mechanism of authorization restriction (i.e. no group or team restrictions in configuration) then all authenticated users will be allowed. Provider-based restrictions, including deprecated values such as GitHubOAuthenticator.orgwhitelist are not affected. Who is impacted? All users of OAuthenticator 0.12.0 and 0.12.1 with JupyterHub 1.2 (JupyterHub Helm chart 0.10.0-0.10.5) who use the admin.whitelist.users configuration in the jupyterhub helm chart or the c.Authenticator.whitelist configuration directly. Users of other deprecated configuration, e.g. c.GitHubOAuthenticator.teamwhitelist are not affected. If you see a log line like this and expect a specific list of…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-384w-5v3f-q499

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-384w-5v3f-q499

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26250

Advisory: Base class whitelist configuration ignored in OAuthenticator
IDs: CVE-2020-26250, GHSA-384w-5v3f-q499
Record: https://patchnext.com/advisories/cve-2020-26250 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: oauthenticator 0.12.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI oauthenticator: affected >= 0.12.0, < 0.12.2; fixed in 0.12.2

## Suggested inspection (read-only)
- `python -m pip show oauthenticator`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on oauthenticator.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-384w-5v3f-q499 (OSV record GHSA-384w-5v3f-q499 lists affected ranges: PyPI oauthenticator >=0.12.0 <0.12.2 (fixed))
- Verified: https://github.com/advisories/GHSA-384w-5v3f-q499 (GitHub-reviewed advisory GHSA-384w-5v3f-q499 lists affected ranges: PyPI oauthenticator >=0.12.0 <0.12.2)

Commands are suggestions: review each one before running it.

Loading voting…