Nokogiri::XML::Schema trusts input by default, exposing risk of XXE vulnerability
CVE-2020-26247GHSA-vr8q-g5c7-m54m
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nokogiri 1.11.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems nokogiri
- Affected
- <= 1.10.10
- Fixed in
- 1.11.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vr8q-g5c7-m54m lists affected ranges: RubyGems nokogiri >=0 <=1.10.10
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2020-26247: 1.18% estimated exploitation activity in the next 30 days; percentile 67.77 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Severity Nokogiri maintainers have evaluated this as Low Severity (CVSS3 2.6). Description In Nokogiri versions <= 1.11.0.rc3, XML Schemas parsed by Nokogiri::XML::Schema are trusted by default, allowing external resources to be accessed over the network, potentially enabling XXE or SSRF attacks. This behavior is counter to the security policy followed by Nokogiri maintainers, which is to treat all input as untrusted by default whenever possible. Please note that this security fix was pushed into a new minor version, 1.11.x, rather than a patch release to the 1.10.x branch, because it is a breaking change for some schemas and the risk was assessed to be "Low Severity". Affected Versions Nokogiri <= 1.10.10 as well as prereleases 1.11.0.rc1, 1.11.0.rc2, and 1.11.0.rc3 Mitigation There are no known workarounds for affected versions. Upgrade to Nokogiri 1.11.0.rc4 or later. If, after upgrading to 1.11.0.rc4 or later, you wish to re-enable network access for resolution of external…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vr8q-g5c7-m54m
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26247 Advisory: Nokogiri::XML::Schema trusts input by default, exposing risk of XXE vulnerability IDs: CVE-2020-26247, GHSA-vr8q-g5c7-m54m Record: https://patchnext.com/advisories/cve-2020-26247 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nokogiri 1.11.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems nokogiri: affected <= 1.10.10; fixed in 1.11.0 ## Suggested inspection (read-only) - RubyGems nokogiri: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nokogiri. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vr8q-g5c7-m54m (GitHub-reviewed advisory GHSA-vr8q-g5c7-m54m lists affected ranges: RubyGems nokogiri >=0 <=1.10.10) Commands are suggestions: review each one before running it.
Loading voting…