Skip to content

← Actionable
High, CVSS 7.5amended

Memory leak in Nanopb

CVE-2020-26243GHSA-85rr-4rh9-hhwh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (nanopb 0.4.4, 0.3.9.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI nanopb

    Affected
    >= 0.3.2, <= 0.3.9.6>= 0.4.0, < 0.4.4
    Fixed in
    0.4.4, 0.3.9.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-26243: 2.66% estimated exploitation activity in the next 30 days; percentile 85.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Decoding specifically formed message can leak memory if dynamic allocation is enabled and an oneof field contains a static submessage that contains a dynamic field, and the message being decoded contains the submessage multiple times. This is rare in normal messages, but it is a concern when untrusted data is parsed. Patches Preliminary patch is available on git and problem will be patched in versions 0.3.9.7 and 0.4.4 once testing has been completed. Workarounds Following workarounds are available: Set the option nounions for the oneof field. This will generate fields as separate instead of C union, and avoids triggering the problematic code. Set the type of the submessage field inside oneof to FTPOINTER. This way the whole submessage will be dynamically allocated and the problematic code is not executed. Use an arena allocator for nanopb, to make sure all memory can be released afterwards. References Bug report: https://github.com/nanopb/nanopb/issues/615 For more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-85rr-4rh9-hhwh

  2. Revision 1 · created ·

    Published from osv record GHSA-85rr-4rh9-hhwh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26243

Advisory: Memory leak in Nanopb
IDs: CVE-2020-26243, GHSA-85rr-4rh9-hhwh
Record: https://patchnext.com/advisories/cve-2020-26243 (revision 2, source checked 26 Oct 2026, 13:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: nanopb 0.4.4, 0.3.9.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI nanopb: affected >= 0.3.2, <= 0.3.9.6; >= 0.4.0, < 0.4.4; fixed in 0.4.4, 0.3.9.7

## Suggested inspection (read-only)
- `python -m pip show nanopb`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on nanopb.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-85rr-4rh9-hhwh (OSV record GHSA-85rr-4rh9-hhwh lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.4 (fixed))
- Verified: https://github.com/advisories/GHSA-85rr-4rh9-hhwh (GitHub-reviewed advisory GHSA-85rr-4rh9-hhwh lists affected ranges: PyPI nanopb >=0.3.2 =0.4.0 <0.4.4)

Commands are suggestions: review each one before running it.

Loading voting…