Skip to content

← Actionable
Medium, CVSS 6.5

Denial of service in geth

CVE-2020-26242GHSA-jm5c-rv3w-w83m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/holiman/uint256 1.1.1; github.com/ethereum/go-ethereum 1.9.18), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-26242: 1.48% estimated exploitation activity in the next 30 days; percentile 73.95 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Denial-of-service (crash) during block processing Details Affected versions suffer from a vulnerability which can be exploited through the MULMOD operation, by specifying a modulo of 0: mulmod(a,b,0), causing a panic in the underlying library. The crash was in the uint256 library, where a buffer underflowed. if d == 0, dLen remains 0 and https://github.com/holiman/uint256/blob/4ce82e695c10ddad57215bdbeafb68b8c5df2c30/uint256.go#L451 will try to access index [-1]. The uint256 library was first merged in this commit, on 2020-06-08. Exploiting this vulnerabilty would cause all vulnerable nodes to drop off the network. The issue was brought to our attention through a bug report, showing a panic occurring on sync from genesis on the Ropsten network. It was estimated that the least obvious way to fix this would be to merge the fix into uint256, make a new release of that library and then update the geth-dependency. - https://github.com/holiman/uint256/releases/tag/v1.1.1 was made…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jm5c-rv3w-w83m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26242

Advisory: Denial of service in geth
IDs: CVE-2020-26242, GHSA-jm5c-rv3w-w83m
Record: https://patchnext.com/advisories/cve-2020-26242 (revision 1, source checked 26 Oct 2026, 15:08 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/holiman/uint256 1.1.1; github.com/ethereum/go-ethereum 1.9.18. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/holiman/uint256: affected >= 0.1.0, < 1.1.1; fixed in 1.1.1
- Go github.com/ethereum/go-ethereum: affected >= 1.9.16, < 1.9.18; fixed in 1.9.18

## Suggested inspection (read-only)
- Go github.com/holiman/uint256: check the installed version with your package manager.
- Go github.com/ethereum/go-ethereum: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/holiman/uint256, github.com/ethereum/go-ethereum.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jm5c-rv3w-w83m (GitHub-reviewed advisory GHSA-jm5c-rv3w-w83m lists affected ranges: Go github.com/ethereum/go-ethereum >=1.9.16 =0.1.0 <1.1.1)

Commands are suggestions: review each one before running it.

Loading voting…