Open redirect in Jupyter Server
CVE-2020-26232GHSA-grfj-wjv9-4f9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 1.0.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- < 1.0.6
- Fixed in
- 1.0.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-grfj-wjv9-4f9v lists affected ranges: PyPI jupyter-server >=0 <1.0.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-grfj-wjv9-4f9v lists affected ranges: PyPI jupyter-server >=0 <1.0.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N · score source
- EPSS
- CVE-2020-26232: 1.00% estimated exploitation activity in the next 30 days; percentile 63.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact What kind of vulnerability is it? Who is impacted? Open redirect vulnerability - a maliciously crafted link to a jupyter server could redirect the browser to a different website. All jupyter servers are technically affected, however, these maliciously crafted links can only be reasonably made for known jupyter server hosts. A link to your jupyter server may appear safe, but ultimately redirect to a spoofed server on the public internet. This originated in jupyter/notebook: https://github.com/jupyter/notebook/security/advisories/GHSA-c7vm-f5p4-8fqh Patches Has the problem been patched? What versions should users upgrade to? jupyterserver 1.0.6 References OWASP page on open redirects For more information If you have any questions or comments about this advisory, or vulnerabilities to report, please email our security list security@ipython.org. Credit: zhuonan li of Alibaba Application Security Team
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-grfj-wjv9-4f9v
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-grfj-wjv9-4f9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26232 Advisory: Open redirect in Jupyter Server IDs: CVE-2020-26232, GHSA-grfj-wjv9-4f9v Record: https://patchnext.com/advisories/cve-2020-26232 (revision 3, source checked 26 Oct 2026, 13:17 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 1.0.6. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected < 1.0.6; fixed in 1.0.6 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-grfj-wjv9-4f9v (OSV record GHSA-grfj-wjv9-4f9v lists affected ranges: PyPI jupyter-server >=0 <1.0.6 (fixed)) - Verified: https://github.com/advisories/GHSA-grfj-wjv9-4f9v (GitHub-reviewed advisory GHSA-grfj-wjv9-4f9v lists affected ranges: PyPI jupyter-server >=0 <1.0.6) Commands are suggestions: review each one before running it.
Loading voting…