Bypass of fix for CVE-2020-15247, Twig sandbox escape
CVE-2020-26231GHSA-r89v-cgv7-3jhx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (october/cms 1.0.470), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist october/cms
- Affected
- >= 1.0.469, <= 1.0.469
- Fixed in
- 1.0.470
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r89v-cgv7-3jhx lists affected ranges: Packagist october/cms >=1.0.469 <=1.0.469
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.2 · CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- EPSS
- CVE-2020-26231: 0.29% estimated exploitation activity in the next 30 days; percentile 21.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A bypass of CVE-2020-15247 (fixed in 1.0.469 and 1.1.0) was discovered that has the same impact as CVE-2020-15247: An authenticated backend user with the cms.managepages, cms.managelayouts, or cms.managepartials permissions who would normally not be permitted to provide PHP code to be executed by the CMS due to cms.enableSafeMode being enabled is able to write specific Twig code to escape the Twig sandbox and execute arbitrary PHP. This is not a problem for anyone that trusts their users with those permissions to normally write & manage PHP within the CMS by not having cms.enableSafeMode enabled, but would be a problem for anyone relying on cms.enableSafeMode to ensure that users with those permissions in production do not have access to write & execute arbitrary PHP. Patches Issue has been patched in Build 470 (v1.0.470) and v1.1.1. Workarounds Apply https://github.com/octobercms/october/commit/d34fb8ab51108495a9a651b841202d935f4e12f7 to your installation manually if unable…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r89v-cgv7-3jhx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26231 Advisory: Bypass of fix for CVE-2020-15247, Twig sandbox escape IDs: CVE-2020-26231, GHSA-r89v-cgv7-3jhx Record: https://patchnext.com/advisories/cve-2020-26231 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: october/cms 1.0.470. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist october/cms: affected >= 1.0.469, <= 1.0.469; fixed in 1.0.470 ## Suggested inspection (read-only) - Packagist october/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on october/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r89v-cgv7-3jhx (GitHub-reviewed advisory GHSA-r89v-cgv7-3jhx lists affected ranges: Packagist october/cms >=1.0.469 <=1.0.469) Commands are suggestions: review each one before running it.
Loading voting…