Skip to content

← Actionable
Critical, CVSS 9.3amended

LDAP authentication bypass with empty password

CVE-2020-26214GHSA-5hmm-x8q8-w5jh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (alerta-server 8.1.0, 7.5.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI alerta-server

    Affected
    >= 8.0.0, < 8.1.0< 7.5.7
    Fixed in
    8.1.0, 7.5.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2020-26214: 65.93% estimated exploitation activity in the next 30 days; percentile 99.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Users may be able to bypass LDAP authentication if they provide an empty password when Alerta server is configure to use LDAP as the authorization provider. Only deployments where LDAP servers are configured to allow unauthenticated binds (eg. default on Active Directory) are affected. Patches A fix has been implemented that returns HTTP 401 Unauthorized response for any authentication attempts where the password field is empty. See https://github.com/alerta/alerta/pull/1345 Workarounds LDAP administrators can disallow unauthenticated bind requests by clients. References https://tools.ietf.org/html/rfc4513#section-5.1.2 https://pypi.org/project/alerta-server/8.1.0/ For more information If you have any questions or comments about this advisory: Add a comment to the issue #1277 Email us at admin@alerta.dev

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-5hmm-x8q8-w5jh

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-5hmm-x8q8-w5jh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26214

Advisory: LDAP authentication bypass with empty password
IDs: CVE-2020-26214, GHSA-5hmm-x8q8-w5jh
Record: https://patchnext.com/advisories/cve-2020-26214 (revision 3, source checked 26 Oct 2026, 13:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: alerta-server 8.1.0, 7.5.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI alerta-server: affected >= 8.0.0, < 8.1.0; < 7.5.7; fixed in 8.1.0, 7.5.7

## Suggested inspection (read-only)
- `python -m pip show alerta-server`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on alerta-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-5hmm-x8q8-w5jh (OSV record GHSA-5hmm-x8q8-w5jh lists affected ranges: PyPI alerta-server >=8.0.0 =0 <7.5.7 (fixed))
- Verified: https://github.com/advisories/GHSA-5hmm-x8q8-w5jh (GitHub-reviewed advisory GHSA-5hmm-x8q8-w5jh lists affected ranges: PyPI alerta-server >=8.0.0 =0 <7.5.7)

Commands are suggestions: review each one before running it.

Loading voting…