Sensitive data exposure in NATS
CVE-2020-26149GHSA-82rf-q3pr-4f6p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (nats 2.0.0-209; nats.ws 1.0.0-111), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-82rf-q3pr-4f6p lists affected ranges: npm nats >=2.0.0-201 =1.0.0-85 <1.0.0-111 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82rf-q3pr-4f6p lists affected ranges: npm nats >=2.0.0-201 =1.0.0-85 <=1.0.0-110
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2020-26149: 1.48% estimated exploitation activity in the next 30 days; percentile 73.88 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Preview versions of two NPM packages and one Deno package from the NATS project contain an information disclosure flaw, leaking options to the NATS server; for one package, this includes TLS private credentials. The connection configuration options in these JavaScript-based implementations were fully serialized and sent to the server in the client's CONNECT message, immediately after TLS establishment. The nats.js client supports Mutual TLS and the credentials for the TLS client key are included in the connection configuration options; disclosure of the client's TLS private key to the server has been observed. Most authentication mechanisms are handled after connection, instead of as part of connection, so other authentication mechanisms are unaffected. For clarity: NATS account NKey authentication is NOT affected. Neither the nats.ws nor the nats.deno clients support Mutual TLS: the affected versions listed below are those where the logic flaw is present. We are including the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-82rf-q3pr-4f6p
- Revision 1 · created ·
Published from osv record GHSA-82rf-q3pr-4f6p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-26149 Advisory: Sensitive data exposure in NATS IDs: CVE-2020-26149, GHSA-82rf-q3pr-4f6p Record: https://patchnext.com/advisories/cve-2020-26149 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: nats 2.0.0-209; nats.ws 1.0.0-111. A vendor fix does not mean a deployment is fixed. ## Affected components - npm nats: affected >= 2.0.0-201, <= 2.0.0-206; fixed in 2.0.0-209 - npm nats.ws: affected >= 1.0.0-85, <= 1.0.0-110; fixed in 1.0.0-111 ## Suggested inspection (read-only) - `npm ls nats --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. - `npm ls nats.ws --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on nats, nats.ws. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-82rf-q3pr-4f6p (OSV record GHSA-82rf-q3pr-4f6p lists affected ranges: npm nats >=2.0.0-201 =1.0.0-85 <1.0.0-111 (fixed)) - Verified: https://github.com/advisories/GHSA-82rf-q3pr-4f6p (GitHub-reviewed advisory GHSA-82rf-q3pr-4f6p lists affected ranges: npm nats >=2.0.0-201 =1.0.0-85 <=1.0.0-110) Commands are suggestions: review each one before running it.
Loading voting…