Skip to content

← Actionable
Medium, CVSS 6.5

Authentication bypass in SilverStripe GraphQL

CVE-2020-26136GHSA-mg2g-8pwj-r2j2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (silverstripe/graphql 4.0.0-alpha2, 3.5.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist silverstripe/graphql

    Affected
    >= 3.0.0, < 3.5.0>= 4.0.0-alpha1, < 4.0.0-alpha2
    Fixed in
    4.0.0-alpha2, 3.5.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
  • CVE-2020-26136: 1.16% estimated exploitation activity in the next 30 days; percentile 67.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The GraphQL module accepts basic-auth as an authentication method by default. This can be used to bypass MFA authentication if the silverstripe/mfa module is installed, which is now a commonly installed module. A users password is still required though. Basic-auth has been removed as a default authentication method. If desired, it can be re-enabled by adding it to the authenticators key of a schema, or on SilverStripe\Graphql\Auth\Handler

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mg2g-8pwj-r2j2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-26136

Advisory: Authentication bypass in SilverStripe GraphQL
IDs: CVE-2020-26136, GHSA-mg2g-8pwj-r2j2
Record: https://patchnext.com/advisories/cve-2020-26136 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: silverstripe/graphql 4.0.0-alpha2, 3.5.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist silverstripe/graphql: affected >= 3.0.0, < 3.5.0; >= 4.0.0-alpha1, < 4.0.0-alpha2; fixed in 4.0.0-alpha2, 3.5.0

## Suggested inspection (read-only)
- Packagist silverstripe/graphql: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on silverstripe/graphql.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mg2g-8pwj-r2j2 (GitHub-reviewed advisory GHSA-mg2g-8pwj-r2j2 lists affected ranges: Packagist silverstripe/graphql >=3.0.0 =4.0.0-alpha1 <4.0.0-alpha2)

Commands are suggestions: review each one before running it.

Loading voting…