HashiCorp Consul Cross-site Scripting vulnerability
CVE-2020-25864GHSA-8xmx-h8rq-h94j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/hashicorp/consul 1.9.5, 1.8.10, 1.7.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/hashicorp/consul
- Affected
- >= 1.9.0, < 1.9.5>= 1.8.0, < 1.8.10< 1.7.14
- Fixed in
- 1.8.10, 1.7.14, 1.9.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8xmx-h8rq-h94j lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 =1.8.0 =0 <1.7.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- EPSS
- CVE-2020-25864: 6.07% estimated exploitation activity in the next 30 days; percentile 93.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
HashiCorp Consul and Consul Enterprise up to version 1.9.4 key-value (KV) raw mode was vulnerable to cross-site scripting. Fixed in 1.9.5, 1.8.10 and 1.7.14.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8xmx-h8rq-h94j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-25864 Advisory: HashiCorp Consul Cross-site Scripting vulnerability IDs: CVE-2020-25864, GHSA-8xmx-h8rq-h94j Record: https://patchnext.com/advisories/cve-2020-25864 (revision 1, source checked 26 Oct 2026, 14:58 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/hashicorp/consul 1.9.5, 1.8.10, 1.7.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/hashicorp/consul: affected >= 1.9.0, < 1.9.5; >= 1.8.0, < 1.8.10; < 1.7.14; fixed in 1.8.10, 1.7.14, 1.9.5 ## Suggested inspection (read-only) - Go github.com/hashicorp/consul: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/hashicorp/consul. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8xmx-h8rq-h94j (GitHub-reviewed advisory GHSA-8xmx-h8rq-h94j lists affected ranges: Go github.com/hashicorp/consul >=1.9.0 =1.8.0 =0 <1.7.14) Commands are suggestions: review each one before running it.
Loading voting…