Skip to content

← Actionable
Medium, CVSS 6.1

MediaWiki Cross-site Scripting (XSS) vulnerability

CVE-2020-25814GHSA-4vr7-m8p8-434h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.35.0, 1.34.3, 1.31.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mediawiki/core

    Affected
    >= 1.31.0, < 1.31.9>= 1.32.0, < 1.34.3>= 1.35.0-rc.0, < 1.35.0
    Fixed in
    1.35.0, 1.31.9, 1.34.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-25814: 1.35% estimated exploitation activity in the next 30 days; percentile 71.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In MediaWiki before 1.31.9 and 1.32.x through 1.34.x before 1.34.3, XSS related to jQuery can occur. The attacker creates a message with [javascript:payload xss] and turns it into a jQuery object with mw.message().parse(). The expected result is that the jQuery object does not contain an <a tag (or it does not have a href attribute, or it's empty, etc.). The actual result is that the object contains an <a href ="javascript... that executes when clicked.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-4vr7-m8p8-434h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-25814

Advisory: MediaWiki Cross-site Scripting (XSS) vulnerability
IDs: CVE-2020-25814, GHSA-4vr7-m8p8-434h
Record: https://patchnext.com/advisories/cve-2020-25814 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.35.0, 1.34.3, 1.31.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/core: affected >= 1.31.0, < 1.31.9; >= 1.32.0, < 1.34.3; >= 1.35.0-rc.0, < 1.35.0; fixed in 1.35.0, 1.31.9, 1.34.3

## Suggested inspection (read-only)
- Packagist mediawiki/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-4vr7-m8p8-434h (GitHub-reviewed advisory GHSA-4vr7-m8p8-434h lists affected ranges: Packagist mediawiki/core >=1.31.0 =1.32.0 =1.35.0-rc.0 <1.35.0)

Commands are suggestions: review each one before running it.

Loading voting…