Skip to content

← Actionable
Medium, CVSS 6.1

MediaWiki Cross-site Scripting (XSS) vulnerability

CVE-2020-25812GHSA-rj9p-8jxj-2ch4

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mediawiki/core 1.35.0, 1.34.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist mediawiki/core

    Affected
    >= 1.34.0, < 1.34.3>= 1.35.0-rc.0, < 1.35.0
    Fixed in
    1.35.0, 1.34.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2020-25812: 1.10% estimated exploitation activity in the next 30 days; percentile 65.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

An issue was discovered in MediaWiki 1.34.x before 1.34.3. On Special:Contributions, the NS filter uses unescaped messages as keys in the option key for an HTMLForm specifier. This is vulnerable to a mild XSS if one of those messages is changed to include raw HTML.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rj9p-8jxj-2ch4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-25812

Advisory: MediaWiki Cross-site Scripting (XSS) vulnerability
IDs: CVE-2020-25812, GHSA-rj9p-8jxj-2ch4
Record: https://patchnext.com/advisories/cve-2020-25812 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mediawiki/core 1.35.0, 1.34.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist mediawiki/core: affected >= 1.34.0, < 1.34.3; >= 1.35.0-rc.0, < 1.35.0; fixed in 1.35.0, 1.34.3

## Suggested inspection (read-only)
- Packagist mediawiki/core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mediawiki/core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rj9p-8jxj-2ch4 (GitHub-reviewed advisory GHSA-rj9p-8jxj-2ch4 lists affected ranges: Packagist mediawiki/core >=1.34.0 =1.35.0-rc.0 <1.35.0)

Commands are suggestions: review each one before running it.

Loading voting…