Improper Control of Dynamically-Managed Code Resources in Crafter CMS Crafter Studio
CVE-2020-25802GHSA-wq3v-3grq-6f86
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.craftercms:crafter-studio 3.1.7, 3.0.27), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.craftercms:crafter-studio
- Affected
- >= 3.0, < 3.0.27>= 3.1, < 3.1.7
- Fixed in
- 3.0.27, 3.1.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-wq3v-3grq-6f86 lists affected ranges: Maven org.craftercms:crafter-studio >=3.0 =3.1 <3.1.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.2 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2020-25802: 1.12% estimated exploitation activity in the next 30 days; percentile 66.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Control of Dynamically-Managed Code Resources vulnerability in Crafter Studio of Crafter CMS allows authenticated developers to execute OS commands via Groovy scripting. This issue affects: Crafter Software Crafter CMS 3.0 versions prior to 3.0.27; 3.1 versions prior to 3.1.7.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-wq3v-3grq-6f86
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-25802 Advisory: Improper Control of Dynamically-Managed Code Resources in Crafter CMS Crafter Studio IDs: CVE-2020-25802, GHSA-wq3v-3grq-6f86 Record: https://patchnext.com/advisories/cve-2020-25802 (revision 1, source checked 26 Oct 2026, 16:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.craftercms:crafter-studio 3.1.7, 3.0.27. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.craftercms:crafter-studio: affected >= 3.0, < 3.0.27; >= 3.1, < 3.1.7; fixed in 3.0.27, 3.1.7 ## Suggested inspection (read-only) - Maven org.craftercms:crafter-studio: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.craftercms:crafter-studio. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-wq3v-3grq-6f86 (GitHub-reviewed advisory GHSA-wq3v-3grq-6f86 lists affected ranges: Maven org.craftercms:crafter-studio >=3.0 =3.1 <3.1.7) Commands are suggestions: review each one before running it.
Loading voting…