Skip to content

← Actionable
Medium, CVSS 5.3

Contao Insert tag injection in forms

CVE-2020-25768GHSA-f7wm-x4gw-6m23

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (contao/contao 4.10.1, 4.9.6, 4.4.52; contao/core-bundle 4.10.1, 4.9.6, 4.4.52), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist contao/contao

    Affected
    >= 4.0.0, < 4.4.52>= 4.5.0, < 4.9.6>= 4.10.0, < 4.10.1
    Fixed in
    4.9.6, 4.4.52, 4.10.1
  • Packagist contao/core-bundle

    Affected
    >= 4.0.0, < 4.4.52>= 4.5.0, < 4.9.6>= 4.10.0, < 4.10.1
    Fixed in
    4.9.6, 4.4.52, 4.10.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2020-25768: 0.82% estimated exploitation activity in the next 30 days; percentile 57.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact It is possible to inject insert tags in front end forms which will be replaced when the page is rendered. Patches Update to Contao 4.4.52, 4.9.6 or 4.10.1. Workarounds Disable the front end login form and do not use form fields with array keys such as fieldname[]. References https://contao.org/en/security-advisories/insert-tag-injection-in-forms For more information If you have any questions or comments about this advisory, open an issue in contao/contao.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f7wm-x4gw-6m23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-25768

Advisory: Contao Insert tag injection in forms
IDs: CVE-2020-25768, GHSA-f7wm-x4gw-6m23
Record: https://patchnext.com/advisories/cve-2020-25768 (revision 1, source checked 26 Oct 2026, 14:19 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: contao/contao 4.10.1, 4.9.6, 4.4.52; contao/core-bundle 4.10.1, 4.9.6, 4.4.52. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist contao/contao: affected >= 4.0.0, < 4.4.52; >= 4.5.0, < 4.9.6; >= 4.10.0, < 4.10.1; fixed in 4.9.6, 4.4.52, 4.10.1
- Packagist contao/core-bundle: affected >= 4.0.0, < 4.4.52; >= 4.5.0, < 4.9.6; >= 4.10.0, < 4.10.1; fixed in 4.9.6, 4.4.52, 4.10.1

## Suggested inspection (read-only)
- Packagist contao/contao: check the installed version with your package manager.
- Packagist contao/core-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on contao/contao, contao/core-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f7wm-x4gw-6m23 (GitHub-reviewed advisory GHSA-f7wm-x4gw-6m23 lists affected ranges: Packagist contao/core-bundle >=4.0.0 =4.5.0 =4.10.0 =4.0.0 =4.5.0 =4.10.0 <4.10.1)

Commands are suggestions: review each one before running it.

Loading voting…