Privilage Escalation in moodle
CVE-2020-25699GHSA-h77r-rp97-7rv4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 3.9.0, < 3.9.3>= 3.8.0, < 3.8.6>= 3.7.0, < 3.7.9>= 3.5, < 3.5.15
- Fixed in
- 3.5.15, 3.7.9, 3.8.6, 3.9.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-h77r-rp97-7rv4 lists affected ranges: Packagist moodle/moodle >=3.9.0 =3.8.0 =3.7.0 =3.5 <3.5.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- CVE-2020-25699: 1.61% estimated exploitation activity in the next 30 days; percentile 75.93 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In moodle, insufficient capability checks could lead to users with the ability to course restore adding additional capabilities to roles within that course. Versions affected: 3.9 to 3.9.2, 3.8 to 3.8.5, 3.7 to 3.7.8, 3.5 to 3.5.14 and earlier unsupported versions. This is fixed in moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15, and 3.10.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-h77r-rp97-7rv4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-25699 Advisory: Privilage Escalation in moodle IDs: CVE-2020-25699, GHSA-h77r-rp97-7rv4 Record: https://patchnext.com/advisories/cve-2020-25699 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 3.9.3, 3.8.6, 3.7.9, 3.5.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 3.9.0, < 3.9.3; >= 3.8.0, < 3.8.6; >= 3.7.0, < 3.7.9; >= 3.5, < 3.5.15; fixed in 3.5.15, 3.7.9, 3.8.6, 3.9.3 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-h77r-rp97-7rv4 (GitHub-reviewed advisory GHSA-h77r-rp97-7rv4 lists affected ranges: Packagist moodle/moodle >=3.9.0 =3.8.0 =3.7.0 =3.5 <3.5.15) Commands are suggestions: review each one before running it.
Loading voting…