Wildfly-OpenSSL memory leak flaw
CVE-2020-25644GHSA-hxj4-885f-grgp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.wildfly.openssl:wildfly-openssl-natives-parent 1.1.3.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.wildfly.openssl:wildfly-openssl-natives-parent
- Affected
- < 1.1.3.Final
- Fixed in
- 1.1.3.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-hxj4-885f-grgp lists affected ranges: Maven org.wildfly.openssl:wildfly-openssl-natives-parent >=0 <1.1.3.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- CVE-2020-25644: 2.37% estimated exploitation activity in the next 30 days; percentile 83.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A memory leak flaw was found in WildFly OpenSSL in versions prior to 1.1.3.Final, where it removes an HTTP session. It may allow the attacker to cause OOM leading to a denial of service. The highest threat from this vulnerability is to system availability.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-hxj4-885f-grgp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2020-25644 Advisory: Wildfly-OpenSSL memory leak flaw IDs: CVE-2020-25644, GHSA-hxj4-885f-grgp Record: https://patchnext.com/advisories/cve-2020-25644 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.wildfly.openssl:wildfly-openssl-natives-parent 1.1.3.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.wildfly.openssl:wildfly-openssl-natives-parent: affected < 1.1.3.Final; fixed in 1.1.3.Final ## Suggested inspection (read-only) - Maven org.wildfly.openssl:wildfly-openssl-natives-parent: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.wildfly.openssl:wildfly-openssl-natives-parent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-hxj4-885f-grgp (GitHub-reviewed advisory GHSA-hxj4-885f-grgp lists affected ranges: Maven org.wildfly.openssl:wildfly-openssl-natives-parent >=0 <1.1.3.Final) Commands are suggestions: review each one before running it.
Loading voting…