Skip to content

← Actionable
High, CVSS 7.5

Integer Overflow/Infinite Loop in the http crate

CVE-2020-25574GHSA-x7vr-c387-8w57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (http 0.1.20), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io http

    Affected
    < 0.1.20
    Fixed in
    0.1.20

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2020-25574: 2.53% estimated exploitation activity in the next 30 days; percentile 84.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

HeaderMap::reserve() used usize::nextpoweroftwo() to calculate the increased capacity. However, nextpoweroftwo() silently overflows to 0 if given a sufficiently large number in release mode. If the map was not empty when the overflow happens, the library will invoke self.grow(0) and start infinite probing. This allows an attacker who controls the argument to reserve() to cause a potential denial of service (DoS). The flaw was corrected in 0.1.20 release of http crate.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x7vr-c387-8w57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-25574

Advisory: Integer Overflow/Infinite Loop in the http crate
IDs: CVE-2020-25574, GHSA-x7vr-c387-8w57
Record: https://patchnext.com/advisories/cve-2020-25574 (revision 1, source checked 26 Oct 2026, 15:34 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: http 0.1.20. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io http: affected < 0.1.20; fixed in 0.1.20

## Suggested inspection (read-only)
- crates.io http: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on http.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x7vr-c387-8w57 (GitHub-reviewed advisory GHSA-x7vr-c387-8w57 lists affected ranges: crates.io http >=0 <0.1.20)

Commands are suggestions: review each one before running it.

Loading voting…