Skip to content

← Actionable
High, CVSS 7.8

Local Privilege Escalation in cloudflared

CVE-2020-24356GHSA-hgwp-4vp4-qmm2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/cloudflare/cloudflared 0.0.0-20200820025921-9323844ea773), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.8 · CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2020-24356: 0.35% estimated exploitation activity in the next 30 days; percentile 28.45 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In cloudflared versions < 2020.8.1 (corresponding to 0.0.0-20200820025921-9323844ea773 on pkg.go.dev) on Windows, if an administrator has started cloudflared and set it to read configuration files from a certain directory, an unprivileged user can exploit a misconfiguration in order to escalate privileges and execute system-level commands. The misconfiguration was due to the way that cloudflared reads its configuration file. One of the locations that cloudflared reads from (C:\etc\) is not a secure by default directory due to the fact that Windows does not enforce access controls on this directory without further controls applied. A malformed config.yaml file can be written by any user. Upon reading this config, cloudflared would output an error message to a log file defined in the malformed config. The user-controlled log file location could be set to a specific location that Windows will execute when any user logs in.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-hgwp-4vp4-qmm2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2020-24356

Advisory: Local Privilege Escalation in cloudflared
IDs: CVE-2020-24356, GHSA-hgwp-4vp4-qmm2
Record: https://patchnext.com/advisories/cve-2020-24356 (revision 1, source checked 26 Oct 2026, 14:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/cloudflare/cloudflared 0.0.0-20200820025921-9323844ea773. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/cloudflare/cloudflared: affected < 0.0.0-20200820025921-9323844ea773; fixed in 0.0.0-20200820025921-9323844ea773

## Suggested inspection (read-only)
- Go github.com/cloudflare/cloudflared: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/cloudflare/cloudflared.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-hgwp-4vp4-qmm2 (GitHub-reviewed advisory GHSA-hgwp-4vp4-qmm2 lists affected ranges: Go github.com/cloudflare/cloudflared >=0 <0.0.0-20200820025921-9323844ea773)

Commands are suggestions: review each one before running it.

Loading voting…